in Development

Netbeans 10 – Cannot find Java 1.8 or higher

Freshly unpacked Netbeans 10 won’t run with either JDK 8 or 11 in PATH and JAVA_HOME.

Solution, either:

  • run netbeans with jdkhome parameter, pointing to your jdk-base folder, e.g.
    netbeans64 --jdkhome c:\jdks\jdk11
  • for a more permanent solution go to subfolder “etc” and open netbeans.conf search the line with netbeans_jdkhome and set the folder there (also uncomment/ remove hashsign) like so
    netbeans_jdkhome="c:\jdks\jdk11"